Em Andamento

Apache 2.4 auth module develop

Apache 2.4 auth module develop

ote:I already have some code works fine , It can valid the user cookie with auth table’s sid, and then get the user gid, check the AllowAuth Directive.

but it need to upgrade to apache2.4.

form auth module is an apache module, it reads user sid cookie from webpages and valid the sid in mysql. If match , user can visit the webpages, and if not match ,suer can’t visit the webpages.

The auth module has an StrictMode , and runs with two order, just like allow,deny and deny,allow orders.

AllowAuth,DenyAuth order:

user’s group_id(or id) and url matches the allow rule, then check the deny rule,

if matches the allow rule , and don't match the deny rule ,pass the user;

if matches the allow rule , and match the deny rules also, deny the user.

if don’t matches the allow rule , and match the deny rules , deny the user.

Don’t matches the two rules, Under StrictMode, deny the user; Not Under StrictMode ,pass the user.

read more , please download the attachment.

Habilidades: Apache, Programação C

Ver mais: develop webpages, apache programming, auth, drupal theme develop module, rules module, develop module opencart, develop module jomsocial, apache upgrade, apache url, cmsms develop module, develop module joomla, develop module elastix, develop module cms simple, joomla timeframe develop module, develop module dolphin, develop module prestashop

Acerca do Empregador:
( 1 comentário ) Nanjing, China

ID do Projeto: #6843111

Premiar a:

Yknox

Hello!!! Thank you for your inviting. I am interested in your project. I am expert in C/C++, Php, mobile. I can do your project. I will wait for your good responding. Thank you very much.

$526 USD em 10 dias
(85 Avaliações)
6.6